Change font size
It is currently Sun Nov 19, 2017 7:02 pm
LairWare Forums
Board index User Chat Ultima III

Ultima III

Ultima III v2.0 Beta Test

Ultima III has thousands of fans around the world, and here's the home for the Mac users among them.

Ultima III v2.0 Beta Test

Postby beastie » Tue Oct 31, 2006 4:02 pm

I'm happy to announce that Ultima III v2.0 for Mac OS X is now ready for beta testing. This is open to the public, and you'll find out all about it here:

http://www.lairware.com/ultima3/beta/

Leon
User avatar
beastie
 
Posts: 443
Joined: Sun Apr 25, 2004 6:51 am

beta won't run

Postby lonwright » Tue Oct 31, 2006 7:35 pm

I just DLed the 2.0 beta. When I ran it, I was told that it had expired and I had to DL a new version. I'm running 10.3.9. Is there a preference or some other system file to throw away? (I have registered a previous version and have my code all ready to type in, but I never get there!)
lonwright
 
Posts: 1
Joined: Tue Oct 31, 2006 7:31 pm

Thanks!!!

Postby Jobbins » Tue Oct 31, 2006 8:12 pm

I've been waiting for this update (it seems) since OSX was released. Many thanks to the guys who put this through, It runs great on my computer, and I love the new music and graphics!!!
1.42 GHz ibook
1 Gig Ram
OS 10.4.8
Jobbins
 
Posts: 1
Joined: Tue Oct 31, 2006 8:09 pm

Same situation

Postby lonadar » Tue Oct 31, 2006 8:34 pm

Running 10.3.9 on a 2001 Dual USB iBook with 512MB. Same expired message straight out of the gates. Also have a previous version registered (would be VERY nice if this would read old registrations, like some programs do). It's been years (I've moved three times) since I last saw my registration code, though...
User avatar
lonadar
 
Posts: 5
Joined: Tue Oct 31, 2006 8:09 pm
Location: Indiana, USA

Postby FortranDragon » Thu Nov 02, 2006 10:30 am

So far so good. I created my own party and started adventuring.

I love the additional tilesets. It would be fun to have the original black and white Macintosh tileset, as well.

(My original registration code worked. Power Mac G5, 10.4.8)
User avatar
FortranDragon
 
Posts: 3
Joined: Sat May 01, 2004 12:45 pm

Postby lonadar » Thu Nov 02, 2006 12:52 pm

I don't remember the Apple II set having that redish tint to it, except on certain kinds of monitors. I'll have to see if I can't find/put-together a clearer version.

Does anyone HAVE a copy of the B&W Ultima III Mac? As long ago as that was, I could see the icons being stored as either a ICNS or PICT resource, which would be easy to extract.

Seems like the pre-expired pre-release problem has to do with not running Mac OS X 10.4. I've heard there was some difference between how 10.4 gave date information, but I don't remember where I heard it.

Yea, beggers can't be choosers, but I hope it doesn't only support 10.4.
User avatar
lonadar
 
Posts: 5
Joined: Tue Oct 31, 2006 8:09 pm
Location: Indiana, USA

Bug report

Postby rufwork » Thu Nov 02, 2006 5:51 pm

I hope this is the appropriate place for bug reports... Accidently killed off the default rogue, terminated her, made another, formed a new party, entered world and I couldn't see pictures for characters 3 & 4. Aborted, rechecked to ensure party had 4 people, started again. Couldn't see profiles for characters 1,2,4. Worked if I clicked on them -- that is, the char stats popped up, but still no headshots.

I had switched from defaults to classic display back to new display during this time.

Quitting and starting up again all the headshots, names, etc on the right side of the screen are displaying properly again.

Fwiw, etc.
rufwork
 
Posts: 1
Joined: Thu Nov 02, 2006 5:48 pm

Lots of stuff ...

Postby beastie » Fri Nov 03, 2006 1:04 pm

I'll first point out that you guys should feel free to make new topics when you want to start talking about something not previously discussed. It would help keep any one topic from getting too huge.

Beta 2 is now up, which fixes the "always expired under 10.3" bug and the crash when some characters speak (such as Lord British telling you to "Seek ye the mark of kings".) I obviously haven't exhaustively tested it, but it runs under 10.3 on my system fine now.

I have the original black & white Macintosh Ultima III around here somewhere, I'll try to extract its tile graphics.

I made the color Apple II graphics tiles look the way they did on my television. Your mileage may vary, particularly if you played it on a IIgs, or if your television was less crap than mine. :D

I'll investigate the disappearing portrait weirdness ...

Thanks, guys.
Leon
User avatar
beastie
 
Posts: 443
Joined: Sun Apr 25, 2004 6:51 am

Postby lonadar » Fri Nov 03, 2006 3:16 pm

Yea, that's what would have done it. Televisions were notorious for shifting Apple II graphics into the red. I still have my old Amdek Color-1 monitor, tried and true. (In fact, I have three. Picked up two for $.50 each at an auction. They make great video-outs!)
User avatar
lonadar
 
Posts: 5
Joined: Tue Oct 31, 2006 8:09 pm
Location: Indiana, USA

Postby lonadar » Fri Nov 03, 2006 3:48 pm

Had to share...

Image
User avatar
lonadar
 
Posts: 5
Joined: Tue Oct 31, 2006 8:09 pm
Location: Indiana, USA


Return to Ultima III



cron

User Control Panel

Login